Testing Yamato

What is the general procedure for installing the fully functional theme? I tried to install from the demo folder using install.php, but in the end I only wound up with a simple bare bones drupal installation with the Yamato logo. I set up a database but originally it wouldn't work so I trashed the settings.php file and renamed the default.settings.php file to settings.php to do the installation. What do I need to do to get the fully functional site so that I can customize it for my own? PS this is not my first theme installation, but the methods I have used for other themes didn't work..

Hi I just installed nevermind theme and there are 3 options for installation: 1. Full installation (=DEMO) This is simply a RESTORE of themesvision demo installation. I guess you wanted to do this? If yes, then you should *not* run install.php. Check your documentation in the zipfile. In my template I have these steps and I assume for Yamato it is the same: - Create a new database in your phpmyadmin/cPanel tools and create database user. - Import the supplied database.sql.zip file (located in Packages folder in your package) into this database. - Upload the "demo" folder to your server. In most cases you will unpack it under the public_html folder, www root folder (windows hosting) or the root folder of your server. - Change the database info in sites/default/settings.php to match the database name, user and password for your new created database. - Done. You can login to manage site folow url: http://domain.com/user. For login see your documentation 2. Profile Installation 3. Theme Only (installation on existing site)
Hello, Thank you for your helpful response. I was able to get to the user login on my localhost however when I use the username/password which is username:"root" password:"root" (same in database and settings.php file) the login fails with the following error: "Sorry, unrecognized username or password. Have you forgotten your password?" Here are the settings in the settings.php file: $databases = array ( 'default' => array ( 'default' => array ( 'database' => 'yamato', 'username' => 'root', 'password' => 'root', 'host' => 'localhost', 'port' => '', 'driver' => 'mysql', 'prefix' => '', ), ), ); The above settings match my database name, location, username, and password in the MySQL server
There is a difference between username/pw of the database and the one of the drupal admin user. What you have in your post is the database user and pw. And this is what you correctly put in the settings.php file. The admin/pw of the website is something different. For your theme you find it in the documentation file, which is index.html in the "documentation" folder of your theme.
Thanks once again for your response. Yes I see. I went to the documentation where the default username and password for the site is admin, admin. Unfortunately I get returned an "Access Denied" meesage page when I put username: admin password: admin
Hello @cleanhoc, What is PHP version you are using?