LayerSlider not compatible with Media 2.x ?

Hi, we purchased Organic Food over 2 years ago. Our original version came with dexp_layerslider
version = "7.x-1.0-beta" Now we've updated to Media 2.x series and it throws an error pertaining to "sites/all/modules/media/wysiwyg_plugins/" — which looks to be a deprecated Media 1.x path that LayerSlider is expecting. What is the current version of LayerSlider and is it fully compatible with Media 2.x? I have come across a version of LayerSlider online that is version = "7.x-1.1" — is that the current version? Even if it is, I would like to have it from the official source, if possible! Thanks.