Jollyness - Multi Purpose, eCommerce Drupal Theme

webforms are all messed up

I tried to create a simple webform and the display is wrong. the checkboxes apear AFTER the text not before as they should

Front page slider is not displaying right.

2 issues at this point: 1. the picture and part of the text are covered by some kind of black grid 2. the main title of the slide appears just when the animation happens then dissapears thoughout the whole slide display. appears again for a fraction of second when the dissapearing animation happens.

Image Style not generated when using views

Everything worked great. After last drupal core update to 7.57, now my views are broken but it only happens when using this theme. I have a few views, on the homepage for example, it shows a thumbnail image, body summary & title of blog article. They are on a grid using views. All works but the image wont show. See the source code and the code seems correct. However on the FTP files in sites/default/files/styles the folders/images are not being created.

Animations stopped working

Some time ago I noticed that the animations done with shortcode or in block settings (e.g. Appears animate: fadeinUp) are not working anymore on our site Sliders however are working normally. Is there a conflict between javascripts, libraries or what?

Drupal 7.56 Drag and Drop not working

The drag and drop layout feature is not working with Drupal 7.56. Do you have any idea what the issue might be?

Support for Drupal 8

Is there an expected date for Jollyness to be available for Drupal 8?

layer slider video not auto play [dexp_layerslider 7.x-1.2]

After upgrading to the latest version:  dexp_layerslider 7.x-1.2,

The Layer Slider video does not seem to autoplay anymore. After some troubleshooting, found some javascript error in sites/all/modules/drupalexp/modules/dexp_layerslider/plugins/rs-plugin/js/jquery.themepunch.revolution.js

On line 3998, the function actually does not exist, therefore breaks the code after that.

Switching that to the older version:

Fixed the issue.



In the demo there is a megamenu (menu Shop). I can not find in the documentation how to create it.

Notice: Undefined index: und in include()

Tickets 5897 and 5898. 

Please assist 

can't move block order or menu items, or anything...

for some reason the drag-drop functionality of the menu items or blocks doesn't work.

When I click on the plus sign in front the line turns yellow, however, it doesn't work dragging.

I tried different browsers and even different computers, the behaviour is the same.

The only 3 extra modules I installed (because I need them) are internalisation, language icons, and module filter. Is there an incompatibility with any of these? 


How do I fix this issue? I cannot nest menus either because of this.